地デジをPCで見たい!

Windows7では、PLEX PX-W3PE と TVTest を使ってPCでTVを見ることができていました。

そして最近、PCのスペックの低さを感じることが多くなり、そろそろPCのスペックを上げたいなと考えていたら、AMDからRyzen5が発売されたのです。

性能やコスパでIntelを超越したCPUと評判が良かったので、AMDを試してみようとPCを組み立て直しました。

もちろん、OSはWindows7からWindows10にアップグレードです。

 

で、今まで使っていた地デジチューナーのPCIカード PLEX PX-W3PE は再利用しようとセットアップしてみたのですが、TVTestで映像が表示されない問題が発生したのです。

 

最初のセットアップではちゃんと地デジがTVTestで映っていて、「Windows10でも意外と簡単に映ったな~」とか安心していたのですが、その後、はまりました。。

 

TVTest を起動しても真っ暗な画面しか表示されず、TVTest 画面の右下に表示されるエラーカウンターだけがカウントアップされ続ける事態になったのです。

チャンネル情報は取得できているので、受信自体はできている模様。

 

なぜ?何が変わった?

 

自問自答を繰り返して設定を見直していたのですが、一向に解決する見込みがなく、ネットで情報を探しても有効な解決法が見つからず、困っていました。

まずは、Windows10でのTVTestセットアップを簡単にまとめてみます。

 

Windows10でのPLEX PX-W3PE + TVTest セットアップでやったこと

  1. TVTest 7.23 の展開
  2. up0625.zip の 「BonDriver_PX_W3PE」からのドライバ展開
  3. BonDriver_PX_W3PE_T0.ini の編集
  4. TVTest_0.7.23fix の適用
  5. チャンネルスキャン
  6. デコーダー「DScaler Mpeg2 Video Decoder」インストール

 

最初はこれでTVTestで地デジを見ることができてました。

 

その後、Windows10への載せ替えに伴うソフトウェアインストールや、Windows Update 適用をやっていたのですが、その途中で気づきました。

 

TVTest を起動しても地デジが映らないことに、、、(汗)

 

最初はTVTestが問題なく映っていたので、何かの設定ファイルがソフトのインストールやWindows Updateで書き換わったのだろうと思い、TVTestを再インストールなど試してみたのですが、問題は解決せず、、

 

途方に暮れていて、半ば諦めかけていたのですが、諦めきれずネットで調べていたところ、デコーダエラーが原因だろうと思うようになり、DSaler Mpeg2 Video Decoder を再インストールなどやってみました。

しかし、それでもTVTestは映らない。。

 

ネットの情報によれば、デコーダーエラーであれば「DSaler Mpeg2 Video Decoder 」をインストールすれば解決したとの情報が多数でした。しかし、新しく組み立てたPCでは映らないのです。

けれども何だかんだ粘れば解決策が見つかるものですね。

最終的には解決策が見つかりましたので、それについて書いておきますね。

 

Windows10 + PLEX PX-W3PE + TVTest で地デジが映るようになった解決方法

解決方法を先に言うと、デーコーダー「TVTestVideoDecoder.ax」を追加したことで解決しました。

 

やったこと。

ここから「TVTestVideoDecoder.ax」をダウンロード。

TVTest は 32bit でセットアップしているので、使うデコーダーのファイルも32bit用を使います。ファイルは圧縮ファイルの以下にあります。

TVTestVideoDecoder_0.2.0_pre2.7z\src\Win32\Release\TVTestVideoDecoder.ax

このファイルをTVTestがあるフォルダーにコピー

 

次に、TVTest.ini の以下の箇所を書き換えます。(TVTestは停止して編集)

Mpeg2Decoder=TVTest DTV Video Decoder

 

そして、TVTestを起動。

すると、「変換に失敗しましたー」みたいなエラーが表示されます。

TVTestの設定を確認してみると、TVTest.iniを書き換えたのでデコーダーが「DScaler Mpeg2 Video Decoder」から「デフォルト」に変わっていました。

(なぜかTVTestVideoDecoderとはなっておらず、デフォルトになってました)

 

その後、デコーダをもともとの設定だった「DScaler Mpeg2 Video Decoder」に変えて、TVTestを再起動。

 

すると、地デジが映りました!

 

 

これで、なぜ映ったかの理由はわかりません。。

デフォルトと表示されるデコーダーが「DScaler Mpeg2 Video Decoder」の前提になっていて、何らかの原因でそれが消えてしまったのか?

それとも、Windows Update でMpeg2デコーダーに何か変更が加えられてしまい、その復旧には「TVTestVideoDecoder.ax」が必要だったのか?

 

こんな推測なのですが、実際のところどうなのかは不明。

 

そもそも「PLEX PX-W3PE」と「TVTest」のセットアップは、ネット公開情報にすべてを依存しており、自分では何が何だかさっぱり理解できてないです、、(爆)

 

とりあえず、結果オーライということで!

 

今回はたまたま「TVTestVideoDecoder.ax」の情報を見つけ、試しににやってみたら映ったって感じでした。

 

もしかすると、同じような事象でお困りの方がいるかもしれないと思い、分かったことをメモってみました。

 

TVTestの詳しいことは理解できていませんが、Windows10にして「PLEX PX-W3PE」+「TVTest」で地デジをPCが見れないって人は試してみる価値あると思います。

 

技術的な質問にはお答えできないですが、「Windows10」「PLEX PX-W3PE」「TVTest」のセットアップでやったことは分かりますので、ご質問ある方は、コメントしてもらえればお答えしますよ。

 

ということで、今回はこのへんで。

ではでは。。